Interface Vitodens 200 avec Raspberry Pi

  1. Jsm
    Jsm
    Ok, pour la correspondance des fonctions et des adresses mémoire, tu te sers de la docs de Viessmann ?
     
    Jsm , 2 Mai 2016
    #61
  2. gchaud
    (92) Hauts-de-Seine
    Non.
    Tu as toutes les infos sur le Wiki, ils ont fait une feuille sur google doc.
     
    gchaud , 2 Mai 2016
    #62
  3. daffyb
    (16) Charente
    Oui, oui, je suis là et je lis les messages.
    Il faut que je cherche ce que tu m'avais envoyé, car je n'avais pas appliqué la mise à jour que tu avais faite chez toi. Je ne sais pas si je vais la retrouver.
    Sinon, je peux, refaire une archive pour @rvaast de ma solution actuelle (j'ai ajouté un slidder pour le mode party et économie)
     - vito2.png
     
    daffyb , 2 Mai 2016
    #63
  4. daffyb
    (16) Charente
    J'ai mis à jour le fichier www.zip
    Il est toujours au même endroit.
     
    daffyb , 2 Mai 2016
    #64
  5. rvaast
    (27) Eure
    merci daffyb ;). tu n'as pas la partie envoie de parametre a tout hazard ?
     
    rvaast , 2 Mai 2016
    #65
  6. daffyb
    (16) Charente
    C'est à dire ??
     
    daffyb , 2 Mai 2016
    #66
  7. rvaast
    (27) Eure
    gchaud a integré, dans la page principale, la gestion des paramètres depuis une table de db.

    c'est surtout cette fonctionnalité qui m’intéresse.
     
    rvaast , 2 Mai 2016
    #67
  8. daffyb
    (16) Charente
    Désolé, je n'arrive pas à mettre la main dessus.
    @gchaud , il va falloir mettre la main au clavier pour nous ressortir ça ;-)
     
    daffyb , 2 Mai 2016
    #68
  9. daffyb
    (16) Charente
    daffyb , 2 Mai 2016
    #69
  10. Jsm
    Jsm
    Merci à vous

    Bizarre : la page est vide ou presque. Il faut taper le code de sa chaudière quelque part ?

    Je n'ai que ce message :
    Optolink_Datenpunkte_Logger_v3
     
    Jsm , 2 Mai 2016
    #70
  11. daffyb
    (16) Charente
    en effet, pareil. Il doit y avoir un problème de droit sur le fichier.
    J'ai envoyé une demande. On verra ce que ça donne.
    Néanmoins, tu as 'normalement' toutes les infos sur la page en html :
    https://openv.wikispaces.com/Adressen
     
    daffyb , 2 Mai 2016
    #71
  12. Jsm
    Jsm
    J'arrive à faire pas mal de chose mais pas à modifier la consigne de la température ambiante. Dans le fichier vito_parameter.c, il utilise en dur (comme partout d'ailleurs...) le code 0x2306. Pour ma Vitodens 222-W (gamme 200/300), il n'a pas de code température dans le tableau d'adresse (IDChaudière=Ox22CB, Dispositif=VCotH01) de cette page https://openv.wikispaces.com/Adressen
     
    Jsm , 2 Mai 2016
    #72
  13. Jsm
    Jsm
    Jsm , 2 Mai 2016
    #73
  14. daffyb
    (16) Charente
    en telnet 127.0.0.1 83
    que te renvoie get deviceid
     
    daffyb , 3 Mai 2016
    #74
  15. Jsm
    Jsm
    Dernière édition: 3 Mai 2016
    Jsm , 3 Mai 2016
    #75
  16. daffyb
    (16) Charente
    donc si c'est une 20cb, c'est comme pour moi.
    En telnet tu mets :
    set raum_soll_temp 20
    et ça mettra la température à 20°C
     
    daffyb , 3 Mai 2016
    #76
  17. Jsm
    Jsm
    OK, c'est ce que je faisais.

    Cela fonctionne un moment mais la chaudière repasse a son ancienne valeur.

    Je pense que c'est à cause de ma commande à distance (un Vitotrol 300). Déjà sur la chaudière, il n'est pas possible de changer la température de consigne : j'ai un message "commande à distance"
     
    Jsm , 3 Mai 2016
    #77
  18. daffyb
    (16) Charente
    ah là, je ne sais pas. Je n'ai qu'un Vitotrol 200. Mais avec lui ça fonctionne quand même lorsque le lance les commandes.
    Il faut juste attendre un peu pour qu'il reflète la modification (sans rien n'y toucher, bien entendu).
    Qu'affiche la chaudière quand tu fais la modif en telnet ? prend elle en compte la commande ?
     
    daffyb , 3 Mai 2016
    #78
  19. Jsm
    Jsm
    Oui, elle le prend en compte. Je n'ai peut-être pas assez attendu ou j'ai touché au vitotrol 300.

    J'ai modifié la consigne d'un degré : je vais voir demain qui prend le dessus : le vitotrol 300 ou le paramètrage via viTalk...
     
    Jsm , 3 Mai 2016
    #79
  20. Jsm
    Jsm
    Resultat : ce matin, le vitotrol 300 avait pris le dessus. Sa priorité est plus forte que la chaudière.

    Sinon, j'ai voulu tester l'interface graphique. J'ai telechargé www.zip dans mon serveur nginx.

    J'ai la fameuse page mais les données ne sont pas mise à jour (que des 10)

    J'ai testé le php : http://mon_ip/home/vito/vito_data.php
    et les valeurs sont bien lues :
    Code:
    mode:1;party:0;saving:0;outdoor_temp:13.20;raum_ist_temp:18.00;ww_ist_temp:41.30;k_ist_temp:39.60;k_abgas_temp:45.50;power:0.0;circ_pomp:0;WW_pomp:0;H_pomp:0;raum_soll_temp:19;red_raum_soll_temp:14;party_soll_temp:19;ww_soll_temp:42;time:00:35:22;starts:94532;runtime_
    Une idée ?



    Je peux regarder la source de Vitalk, mais cela marche comment ? rg + premier codage + code + valeur ?

    EDIT : j'ai trouvé ce point :
    rg + adresse mémoire (ex 0x2323 pour le mode) + nombre de byte :

    Code:
    $rg 2323 1
    0;
    $s mode 1
    OK
    $rg 2323 1
    1;

    Encore une question : le passage en mode vacances est possible ? code ?
     
    Dernière édition: 4 Mai 2016
    Jsm , 3 Mai 2016
    #80
Chargement...
Autres sujets similaires Forum Date

Fonctionnement tuyauterie chaudière viessmann vitodens 222 F

Chauffage Jeudi à 21:26

Panne Viessmann Vitodens 222 WSB

Chauffage 12 Novembre 2016

VITODENS 222-W Un bon choix dans mon cas ?

Chauffage 11 Novembre 2016

Vitodens 222-f et pente et durée monter en température

Chauffage 6 Novembre 2016

acces codage vitodens

Chauffage 29 Octobre 2016