Interface Vitodens 200 avec Raspberry Pi

  1. nini57
    (57) Moselle
    je ne peux pas me mettre physiquement sur le vitotronic il n'y a pas de port optolink
     
    nini57 , 8 Janvier 2020
    #301
  2. Arty68
    (68) Haut-Rhin
    Sinon tu parlais ici de systeme domotique tu utilise lequel sans être indiscret ?
     
    Arty68 , 8 Janvier 2020
    #302
  3. Arty68
    (68) Haut-Rhin
    Quand je dis "Moi je changerai déja physiquement " c'est avec tes doigts :D

    C'est modifier la valeur de la consigne "à l'ancienne" directement avec le vito

    L'idée c'est changer manuellement (avec tes doigts sur le vito) et ensuite via le vClient ou le telnet (partie 7 ici : https://github.com/openv/openv/wiki/vcontrold-mit-Raspberry-Pi) qui interroge ton interface optique faire tous les getTemp qui existent dans ton vito.xml et comparer avec la valeur que tu as entré manuellement avec tes doigts :D


    Ca va te donner des log de ce type la en debug on:

    DEBUG:Mon Dec 30 19:19:15 2019 : >SENT: 04
    DEBUG:Mon Dec 30 19:19:15 2019 : >FRAMER: no preset result
    DEBUG:Mon Dec 30 19:19:15 2019 : Waiting for 05
    DEBUG:Mon Dec 30 19:19:16 2019 : <RECV: 05 (1230.0 ms)
    DEBUG:Mon Dec 30 19:19:16 2019 : >SENT: 01
    DEBUG:Mon Dec 30 19:19:16 2019 : >SENT: C7
    DEBUG:Mon Dec 30 19:19:16 2019 : >SENT: F8
    DEBUG:Mon Dec 30 19:19:16 2019 : >SENT: 04
    DEBUG:Mon Dec 30 19:19:16 2019 : >SENT: 04
    DEBUG:Mon Dec 30 19:19:16 2019 : >FRAMER: no preset result
    DEBUG:Mon Dec 30 19:19:16 2019 : <RECV: len=1 20 (40.0 ms)
    DEBUG:Mon Dec 30 19:19:16 2019 : <RECV: len=3 53 (50.0 ms)
    DEBUG:Mon Dec 30 19:19:16 2019 : <RECV: received 20 53 01 2B
    DEBUG:Mon Dec 30 19:19:16 2019 : 20 53 01 2B -> V200WB2 ID=2053 Protokoll:GWG_VBEM
    DEBUG:Mon Dec 30 19:19:16 2019 : V200WB2 ID=2053 Protokoll:GWG_VBEM
     
    Dernière édition: 8 Janvier 2020
    Arty68 , 8 Janvier 2020
    #303
  4. gchaud
    (92) Hauts-de-Seine
    Peux tu nous faire une photo de la façade de ta chaudière STP?
    L'optoloink communique avec les 2 les sur la façade.
     
    gchaud , 8 Janvier 2020
    #304
  5. nini57
    (57) Moselle
    haha effectivement je n'avais pas compris lol, je vais essayer de faire des essaies ce soir et je te tiendrai au courant
    pour mon système domotique j'utilise Domoticz
     
    nini57 , 8 Janvier 2020
    #305
  6. Arty68
    (68) Haut-Rhin
    Parfait moi aussi, alors le plus simple c'est de passer directement par vitoctrld et si ca marche correctement tu peux te faire des devices virtuels et les mettre a jour via mqtt c'est ce que je fais et ca fonctionne tres bien
     

    Fichiers attachés:

    Arty68 , 8 Janvier 2020
    #306
  7. nini57
    (57) Moselle
    Bon j'ai essayé avec tous les vito.xml et vcontrol.xml que j'ai trouvé, je n'ai rien qui fonctionne à 100% je ne récupère toujours pas les bonnes valeurs
     
    Dernière édition: 9 Janvier 2020
    nini57 , 9 Janvier 2020
    #307
  8. Arty68
    (68) Haut-Rhin
    Ok , pourrai tu nous faire un schema du branchement de ce qui pars de ta chaudiere et de ce qui pars de ta vitrotonic pour qu'on puisse comprendre ce que controle ta vitrotonic en fait. Et egallement un photo de la facade de ta chaudiere

    Ce qu'il va te falloir faire sinon c'est une sorte de scanneur d'adresses. Je m'en suis fait un en language python mais tu vas devoir l'adapter a ton protocole.
     
    Arty68 , 9 Janvier 2020
    #308
  9. nini57
    (57) Moselle
    super je suis preneur pour le scanner d’adresses, je t'envoie les photos ce soir
     
    Dernière édition: 9 Janvier 2020
    nini57 , 9 Janvier 2020
    #309
  10. Arty68
    (68) Haut-Rhin
    Arty68 , 9 Janvier 2020
    #310
  11. nini57
    (57) Moselle
    voici les photos, autre question mais je pense que cela est normal quand je regarde le planning du mode absent sur la regl je ne vois pas ce que j'ai parametré sur vitalk.
    Mais cela est normal car c'est vitalk qui envoit la consigne de temp en fonction de l'heure non ?  - IMG_1093.jpeg  - IMG_1094.jpeg
     
    nini57 , 9 Janvier 2020
    #311
  12. Arty68
    (68) Haut-Rhin
    Ok du vitotronic à la chaudiere, il y a rien d'autre que le cable KM Bus ?
    Si oui je ne comprend pas vraiment à quoi elle sert la vitotronic en fait.

    Pourrai tu faire encore un schema rapide du branchement du vitotronic et ce qui en sort on ne voit pas bien sur la photo ?

    Pour ton scanneur comment est branché ton interface sur le raspberry ? sur le GPIO ?
    Si oui il va falloir utiliser : https://pyserial.readthedocs.io/en/latest/shortintro.html

    Chez moi c'est "branché" en wifi via un esp8266.
    Ensuite , il faudrai aussi que je sache le type protocle que tu utilise KW ou 300 ?
    Tu peux le voir avec le getDevType du vcontrold

    En attendant tu peux deja commencer par installer python3 sur ton raspberry :

    https://www.digitalocean.com/commun...set-up-a-programming-environment-on-debian-10
     
    Dernière édition: 10 Janvier 2020
    Arty68 , 10 Janvier 2020
    #312
  13. Arty68
    (68) Haut-Rhin
    Je comprend pas bien ta question mais on verra ca plus tard l'objectif pour l'instant est de comprendre ta installation d'abord
     
    Arty68 , 10 Janvier 2020
    #313
  14. nini57
    (57) Moselle
    La réponse de GetDevType est UNKNOW je ne sais donc pas quel est le protocole
    Cependant Vitalk me remonte un deviceID 0X20C9

    deviceid: 0x20c9 ;

    mode: 2 ;

    time: 21:41:46 ;

    saving: 0 ;

    party: 0 ;

    mode_text: Heating and hot water ;

    outdoor_temp: 20.00 oC;

    outdoor_temp_tp: 0.00 oC;

    outdoor_temp_smooth: 0.00 oC;

    k_ist_temp: 55.50 oC;

    k_ist_temp_tp: 55.50 oC;

    k_soll_temp: 50.00 oC;

    k_abgas_temp: 56.00 oC;

    ww_soll_temp: 50 oC;

    ww_ist_temp: 47.70 oC;

    ww_ist_temp_tp: 47.70 oC;

    ww_offset: 20 K;

    vl_soll_temp: 74.00 oC;

    raum_soll_temp: 22 oC;

    raum_ist_temp: 20.00 oC;

    red_raum_soll_temp: 16 oC;

    party_soll_temp: 22 oC;

    niveau: 0 K;

    neigung: 0.8 ;

    pp_max: 65 %;

    pp_min: 30 %;

    starts: 495364 ;

    runtime_h: 17110.5 h;

    runtime: 61597745 s;

    power: 63.0 %;

    ventil: 1 ;

    ventil_text: Heating ;

    pump_power: 0 %;

    circ_pomp: 1 ;

    WW_pomp: 0 ;

    H_pomp: 1 ;
     
    Dernière édition: 10 Janvier 2020
    nini57 , 10 Janvier 2020
    #314
  15. Arty68
    (68) Haut-Rhin
    Pourrai tu faire un debug on puis un getDevType et nous envoyer le log ?
     
    Arty68 , 11 Janvier 2020
    #315
  16. nini57
    (57) Moselle
    p.p1 {margin: 0.0px 0.0px 0.0px 0.0px; font: 10.0px Monaco; color: #f2f2f2; background-color: #000000; background-color: rgba(0, 0, 0, 0.8)} span.s1 {font-variant-ligatures: no-common-ligatures}

    vctrld>getDevType

    DEBUG:Sun Jan 12 18:16:29 2020 : Befehl: getDevType

    DEBUG:Sun Jan 12 18:16:29 2020 : >SEND: 04

    DEBUG:Sun Jan 12 18:16:29 2020 : >FRAMER: no preset result

    DEBUG:Sun Jan 12 18:16:29 2020 : Warte auf 05

    DEBUG:Sun Jan 12 18:16:31 2020 : <RECV: 05 (1780.0 ms)

    DEBUG:Sun Jan 12 18:16:31 2020 : >SEND: 01

    DEBUG:Sun Jan 12 18:16:31 2020 : >SEND: F7

    DEBUG:Sun Jan 12 18:16:31 2020 : >SEND: 00

    DEBUG:Sun Jan 12 18:16:31 2020 : >SEND: F8

    DEBUG:Sun Jan 12 18:16:31 2020 : >SEND: 08

    DEBUG:Sun Jan 12 18:16:31 2020 : >FRAMER: no preset result

    DEBUG:Sun Jan 12 18:16:31 2020 : <RECV: len=8 20 (30.0 ms)

    DEBUG:Sun Jan 12 18:16:31 2020 : <RECV: received 20 C9 00 2B 00 00 01 14

    DEBUG:Sun Jan 12 18:16:31 2020 : 20 C9 00 2B 00 00 01 14 -> UNKNOWN

    DEBUG:Sun Jan 12 18:16:31 2020 : UNKNOWN

    UNKNOWN

    vctrld>
     
    nini57 , 12 Janvier 2020
    #316
  17. Arty68
    (68) Haut-Rhin
    Ok c'est du KW
     
    Arty68 , 12 Janvier 2020
    #317
  18. nini57
    (57) Moselle
    ok merci du coup que dois-je faire ?
     
    nini57 , 12 Janvier 2020
    #318
  19. Arty68
    (68) Haut-Rhin
    Tu as installé python3 sur ton raspberry ?
    Je vais essayer de te faire un scanneur d'adresse
     
    Arty68 , 13 Janvier 2020
    #319
  20. nini57
    (57) Moselle
    oui python est bien installé
     
    nini57 , 13 Janvier 2020
    #320
Chargement...
Autres sujets similaires Forum Date

[Résolu] Problème avec chaudière Viessmann Vitodens 200w !

Chauffage 9 Mars 2020

Vitodens 222F : réglage et domotique

Chauffage 5 Mars 2020

Defaut C5 sur chaudière Vitodens 333

Chauffage 21 Février 2020

Viessman Vitodens 200 WB2A - Vitotronic 200 - courbe de chauffe ??

Chauffage 4 Janvier 2020

Vitodens 200-W pas de code erreur

Chauffage 1 Novembre 2019